分类 kali_liux 下的文章

0x00.安装增强功能失败一般是因为内核版本与增强包不一致

0x01.首先我们先编辑配置文件更新一下源

root@0verflow# vim /etc/apt/sources.list

0x02.在配置文件里面插入源链接


deb http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
deb-src http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
deb http://mirrors.ustc.edu.cn/kali-security kali-current/updates main contrib non-free
deb-src http://mirrors.ustc.edu.cn/kali-security kali-current/updates main contrib non-free

0x03.保存退出源文件,并且用命令更新下引索文件和更新系统。为什么我们先是更新系统,因为安装增强功能需要 linux-headers,但是目前对4.3版本的Kali官方的源是没有 linux-headers的,所以先更新系统到4.5或更高的版本

root@0verflow# apt-get update
root@0verflow# apt-get list-upgrade

0x04.安装 gcc 和 make 和 linux-headers

root@0verflow# apt-get install gcc make linux-headers-$(uname -r)

0x05.等安装完这些东西之后,就可以安装VirtualBox的增强功能了,赋予 VBoxLinuxAdditions.run 777的权限

root@0verflow# chmod 777 VBoxLinuxAdditions.run

0x06.然后运行安装脚本

root@0verflow# ./VBoxLinuxAdditions.run

0x07.最后不出意外应该安装成功